Friday, September 4, 2015

R9 Fury Unlocking Simplified

As you probably already know it is possible to unlcok the R9 Fury from it's normal 3584 stream processor to 3776 processor, 3840 processor or even 4096 processors at which point it's basically a Fury X.

This guide is a simplification of this guide. When I was doing the process for the first time it took me close to an hour to get through it all. So this is my take on how to make the guide simpler.


First of all download this file  (dropbox mirror) and python 2(Python 3 does not work!). The filecontains all the programs and scripts that you need to unlock your Fury. You need Python to run one of the applications that makes flashing possible.
I hope that none of the software creators have a problem with me putting everything together and re-uploading it. If you do you can just leave a comment and I'll take it down again.

Unzip the folder to where ever you want. Then go to the folder CUinfo and run the program "cuinfo16".
And you'll get to see something like this:
If the last line says something like "X CUs are disabled by HW lock, override is possible at your own risk." You can try flash the card.

In order to flash the card first go into the ATiFlash folder and run the script called "BackupBIOS". This will create a file called: FuryBIOS.rom. Copy and paste this file(DO NOT CUT AND PASTE! THIS IS YOUR WORKING VANILLA BIOS IF THINGS GO SOUR YOU WILL NEED IT!) to the AtomTool folder. Then go back to ATiFlash rename the FuryBIOS.rom to FuryBIOS1.rom and then flip the BIOS switch on the top edge of your Fury. Now run the "BackupBIOS" script again. Once it's done flip your BIOS switch back to it's original position. Now go into the AtomTool folder and run the "makeroms" script. This will creat 3 files called:
3776spBIOS.rom
3840spBIOS.rom
4096spBIOS.rom

Copy these to the ATiFlash folder and run the script called "Flash XXXXSP BIOS" the XXXX stands for how many cores will be unlocked. First run the 3776 core script then restart the computer and check using GPU-z that you now have 3776 cores. If you do stress test the GPU by playing some games or running a stress test. If it's stable you can run the "Flash 3840SP BIOS" script. Then do the same that you did to check that the 3776 BIOS worked. If it does great and you can run the "Flash 4096SP BIOS" script. Then check that it worked the same way you check that the 3776SP and 3840SP BIOS worked.

If at any point the GPU is not stable just go into the ATiFlash folder and run the script that applies the previous BIOS that worked using the corresponding script. If the 4096SP BIOS didn't work flash the 3840SP BIO. If the 3840SP BIOS didn't work flash the 3776SP BIO. If the 3776SP BIOS didn't work run the "Flash Backup BIOS" script.

If the system fails to boot up after a BIOS flash flip the BIOS switch on your R9 Fury and boot up. Once windows is loaded flip the BIOS switch back to the broken BIOS and flash the last working BIOS the same way I explained in the previous paragraph.

If you run into any issues leave a comment down bellow. If you liked this guide please like and share this post potentially sign up for email updates about the blog.

The R9 Fury and Fury X volt modding guide is now up!

Thank you to Cooler Master for powering this blog with their amazing V series power supplies.

50 comments:

  1. Replies
    1. No idea. I haven't tested it and I'm pretty sure the AtomTool only works for Fiji cards

      Delete
    2. Welll if you could test it be sure to let me know. Great post

      Delete
  2. I can´t download the file you put on Google Drive(page does not load). Can you reupload it or put it somewhere else?

    ReplyDelete
  3. The thread on OCN is titled Activation of cores in Hawaii, Tonga and Fiji ,

    290 is Hawaii .

    ReplyDelete
  4. When I attempt to run the backupbios.bat command prompt opens for a split second and then vanishesand no backup is made, any help?

    ReplyDelete
    Replies
    1. Disregard me, I am a complete ding dong. I had to put 0*xxxx for my fury code, managed to get all 8 of my cores open, just need to stress test it some more.

      Delete
    2. Nooo, tell us what you did!

      Delete
  5. When i start any script on a win 10 pc cmd pops up for 1 sec instantly closes and nothing happens

    does this not work on windows 10?

    ReplyDelete
    Replies
    1. I have the same issue, really looking for help.

      Delete
    2. Late reply but what fixed it for me was running ATIWinFlash.exe in Admin mode first then exiting it after it opened.

      After you do that you should be able to run the .bat files without any issue :)

      Delete
  6. strange issue I am having with my Strix card. The 3776 and 3840 BIOS flashers are flipped for me. IE flashing the 3776 bios results in GPU Z displaying 3840. no appreciable increase in performance using either.

    Nice post and setup though. Thanks!

    ReplyDelete
    Replies
    1. yeah a made a mistake in the scrip with labeling. The 3840BIOS has the 3776 BIOS and vice versa. It doesn't really matter that much.

      Delete
  7. I just wanted to drop in to say thank you. This blog is excellent and extremely helpful.
    I was only able to get to 3776 on my fury as anything above that gives artifacts, but hey, a free performance boost is a free performance boost!

    ReplyDelete
  8. sadly didn't work on my saphire fury nitro says
    Adapters detected: 1
    Card #1 PCI ID: 1002:7300 - 174B:E331
    DevID [7300] Rev [CB] (0), memory config: 0x00000000 (unused)
    Fiji-class chip with 16 compute units per Shader Engine
    SE1 hw/sw: 00030001 / 00000000 [..............xx]
    SE2 hw/sw: 00030001 / 00000000 [..............xx]
    SE3 hw/sw: 00050001 / 00000000 [.............x.x]
    SE4 hw/sw: 00030001 / 00000000 [..............xx]
    56 of 64 CUs are active. HW locks: 8 (R/O) / SW locks: 0 (R/W).
    Sorry, all 8 disabled CUs can't be unlocked by BIOS replacement.

    plain overclocking for me

    ReplyDelete
  9. Good news everyone!
    Successfully unlocked 4Low!

    Bad news everyone!
    No performance increase....

    :(

    ReplyDelete
  10. Hey, the 3776 flash works fine, but the 3840 flash only unlocks 3712 cores... any idea why?

    ReplyDelete
    Replies
    1. for me 3776sp going to 3840 sp ...

      Delete
    2. The file names are mixed up. 3776 is 3840 and 3840 us 3776

      Delete
    3. Thanks for your fast reply ! i'll try 4096 later and repost here

      Delete
  11. Adapters detected: 1
    Card #1 PCI ID: 1002:7300 - 174B:E331
    DevID [7300] Rev [CB] (0), memory config: 0x00000000 (unused)
    Fiji-class chip with 16 compute units per Shader Engine
    SE1 hw/sw: 00030001 / 00000000 [..............xx]
    SE2 hw/sw: 00050001 / 00000000 [.............x.x]
    SE3 hw/sw: 00030001 / 00000000 [..............xx]
    SE4 hw/sw: 00030001 / 00000000 [..............xx]
    56 of 64 CUs are active. HW locks: 8 (R/O) / SW locks: 0 (R/W).
    Sorry, all 8 disabled CUs can't be unlocked by BIOS replacement.

    No luck!

    ReplyDelete
    Replies
    1. I've tried overclocking instead.Currently got the core @ 1135MHz stable and hoping for a bit more with further testing. Better than nothing :)

      Delete
  12. good guide, but did not have luck with unlockable piece, maybe next time

    but looks like good ASIC quality and undervolting extremely well

    ReplyDelete
  13. If you flash your fury and, god forbid something happens to it and you need to send it back could you just go back to the original bios and still make use of the warrantie?

    ReplyDelete
  14. This comment has been removed by the author.

    ReplyDelete
  15. Have a 3 day old Fury Strix here.
    Single bios but yolo.

    Adapters detected: 1
    Card #1 PCI ID: 1002:7300 - 1043:049E
    DevID [7300] Rev [CB] (0), memory config: 0x00000000 (unused)
    Fiji-class chip with 16 compute units per Shader Engine
    SE1 hw/sw: 00030000 / 00000000 [..............xx]
    SE2 hw/sw: 08010000 / 00000000 [....x..........x]
    SE3 hw/sw: 00030000 / 00000000 [..............xx]
    SE4 hw/sw: 00030000 / 00000000 [..............xx]
    56 of 64 CUs are active. HW locks: 8 (R/W) / SW locks: 0 (R/W).
    8 CU's are disabled by HW lock, override is possible at your own risk.

    Yeaaaaaah boooooiiiii!

    Adapters detected: 1
    Card #1 PCI ID: 1002:7300 - 1043:049E
    DevID [7300] Rev [CB] (0), memory config: 0x00000000 (unused)
    Fiji-class chip with 16 compute units per Shader Engine
    SE1 hw/sw: 00000000 / 00000000 [................]
    SE2 hw/sw: 00000000 / 00000000 [................]
    SE3 hw/sw: 00000000 / 00000000 [................]
    SE4 hw/sw: 00000000 / 00000000 [................]
    64 of 64 CUs are active. HW locks: 0 (R/W) / SW locks: 0 (R/W).
    All CUs in this chip are already active.

    Stable, no artifacts, good performance boost.
    Still really shouldn't have risked it...

    ReplyDelete
    Replies
    1. Same results for me !!!
      Is it still working fine with you until now?
      How about overclocking it, anything until now?

      Delete
  16. This comment has been removed by the author.

    ReplyDelete
  17. This comment has been removed by the author.

    ReplyDelete
  18. Adapters detected: 1
    Card #1 PCI ID: 1002:7300 - 174B:E329
    DevID [7300] Rev [CB] (0), memory config: 0x00000000 (unused)
    Fiji-class chip with 16 compute units per Shader Engine
    SE1 hw/sw: 00000000 / 00000000 [................]
    SE2 hw/sw: 00000000 / 00000000 [................]
    SE3 hw/sw: 00000000 / 00000000 [................]
    SE4 hw/sw: 00000000 / 00000000 [................]
    64 of 64 CUs are active. HW locks: 0 (R/W) / SW locks: 0 (R/W).
    All CUs in this chip are already active.
    ...
    ...
    Was able to unlock all cores!!!! Thank you much! this post is so helpful!


    Before unlocking test score:
    Unigine Heaven Benchmark 4.0
    FPS:
    110.8
    Score:
    2791
    Min FPS:
    31.6
    Max FPS:
    193.2
    ...........................
    AFTER UNLOCKING TEST SCORE:
    Unigine Heaven Benchmark 4.0
    FPS:
    116.3
    Score:
    2930
    Min FPS:
    31.2
    Max FPS:
    200.9

    ReplyDelete
    Replies
    1. However, I am not able to overclock it beyond the stock core clock for some reason. Anyone know what is causing that?

      Delete
    2. I am using Sapphire TRIXX overclocker

      Delete
  19. Solved the problem of not able to overclock my unlocked r9 fury. The Sapphire TRIXX was tripping. I uninstalled it and I am using MSI After burner and it is working fine.
    Here are some results on a slight over clock of 1055MHZ clock speed, 550MHZ memory speed, BEFORE and AFTER fully UNLOCKING my R9 FURY.

    System Specs:
    CPU model:
    Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz (3591MHz) x4
    GPU model:
    Intel(R) HD Graphics 4600 20.19.15.4474/AMD Radeon (TM) R9 Fury Series 21.19.151.3 (4095MB) x1
    RAM: 16GB at 1333Mhz (don't know yet how to use the full 1600Mhz,lol)


    Unigine Heaven Benchmark 4.0

    Settings:
    Render: Direct3D11
    Mode: 1920x1080 4xAA fullscreen
    Preset: Custom
    Quality: High
    Tessellation: Disabled
    **********************************************************
    BEFORE UNLOCKING: 1055mhz clock speed, 550mhz memory speed.
    **********************************************************
    Average FPS:
    113.3
    Score:
    2854
    Min FPS:
    30.0
    Max FPS:
    172.0

    **********************************************************
    BEFORE UNLOCKING: 1055mhz clock speed, 550mhz memory speed.
    **********************************************************

    FPS:
    121.4
    Score:
    3057
    Min FPS:
    31.1
    Max FPS:
    198.6

    ReplyDelete
  20. So if cuInfo says "Sorry, all 8 disabled CUs can't be unlocked by BIOS replacement." you are flat out of luck? Out of curiosity has anyone tried anyway just to see what happens?

    ReplyDelete
    Replies
    1. Adapters detected: 1
      Card #1 PCI ID: 1002:7300 - 174B:E331
      DevID [7300] Rev [CB] (0), memory config: 0x00000000 (unused)
      Fiji-class chip with 16 compute units per Shader Engine
      SE1 hw/sw: 00030001 / 00000000 [..............xx]
      SE2 hw/sw: 00030001 / 00000000 [..............xx]
      SE3 hw/sw: 00030001 / 00000000 [..............xx]
      SE4 hw/sw: 00030001 / 00000000 [..............xx]
      56 of 64 CUs are active. HW locks: 8 (R/O) / SW locks: 0 (R/W).
      Sorry, all 8 disabled CUs can't be unlocked by BIOS replacement.

      Sad

      Delete
  21. Hey guys, perhaps someone can point me on the issue that came up. I have the Sapphire R9 Fury Tri-X and came across this blog "awesome blog btw". I did everything successfully as explained above. I went the Flash 3840SP BIOS and everything worked fine after a GPU stress test, so I decided to to unlock all the cores with Flash 4096SP BIOS and got artifacts. I went back to 3840SP BIOS and still had artifacts even the night prior it worked fine. I then flashed BackupBIOS and and everything is fine again but when I try to back to 3840SP BIOS I get artifacts again.
    What can possibly cause this?
    Tx guys.

    Adapters detected: 1
    Card #1 PCI ID: 1002:7300 - 174B:E329
    DevID [7300] Rev [CB] (0), memory config: 0x00000000 (unused)
    Leakage 0x286 (ASIC Quality 63.1%)
    Fiji-class chip with 16 compute units per Shader Engine
    SE1 hw/sw: 00030000 / 00000000 [..............xx]
    SE2 hw/sw: 00030000 / 00000000 [..............xx]
    SE3 hw/sw: 00030000 / 00000000 [..............xx]
    SE4 hw/sw: 00030000 / 00000000 [..............xx]
    56 of 64 CUs are active. HW locks: 8 (R/W) / SW locks: 0 (R/W).
    8 CU's are disabled by HW lock, override is possible at your own risk.

    ReplyDelete
    Replies
    1. This comment has been removed by the author.

      Delete
  22. This comment has been removed by the author.

    ReplyDelete
  23. This comment has been removed by the author.

    ReplyDelete
  24. Hey guys, perhaps someone can point me on the issue that came up. I have the Sapphire R9 Fury Tri-X and came across this blog "awesome blog btw". I did everything successfully as explained above. I went the Flash 3840SP BIOS and everything worked fine after a GPU stress test, so I decided to to unlock all the cores with Flash 4096SP BIOS and got artifacts. I went back to 3840SP BIOS and still had artifacts even the night prior it worked fine. I then flashed BackupBIOS and and everything is fine again but when I try to back to 3840SP BIOS I get artifacts again.
    What can possibly cause this?
    Tx guys.

    Adapters detected: 1
    Card #1 PCI ID: 1002:7300 - 174B:E329
    DevID [7300] Rev [CB] (0), memory config: 0x00000000 (unused)
    Leakage 0x286 (ASIC Quality 63.1%)
    Fiji-class chip with 16 compute units per Shader Engine
    SE1 hw/sw: 00030000 / 00000000 [..............xx]
    SE2 hw/sw: 00030000 / 00000000 [..............xx]
    SE3 hw/sw: 00030000 / 00000000 [..............xx]
    SE4 hw/sw: 00030000 / 00000000 [..............xx]
    56 of 64 CUs are active. HW locks: 8 (R/W) / SW locks: 0 (R/W).
    8 CU's are disabled by HW lock, override is possible at your own risk.

    ReplyDelete
  25. Hey i have a question
    Can you flip the bios switch on the gpu whilst the pc is running? :)

    ReplyDelete
  26. I am having one problem with doing this. I have the ASUS R9 Fury and cannot locate a bios switch nor info on it.
    Also, for reference:
    Adapters detected: 1
    Card #1 PCI ID: 1002:7300 - 1043:049E
    DevID [7300] Rev [CB] (0), memory config: 0x00000000 (unused)
    Fiji-class chip with 16 compute units per Shader Engine
    SE1 hw/sw: 00030000 / 00000000 [..............xx]
    SE2 hw/sw: 00030000 / 00000000 [..............xx]
    SE3 hw/sw: 00030000 / 00000000 [..............xx]
    SE4 hw/sw: 00030000 / 00000000 [..............xx]
    56 of 64 CUs are active. HW locks: 8 (R/W) / SW locks: 0 (R/W).
    8 CU's are disabled by HW lock, override is possible at your own risk.

    ReplyDelete
  27. So my card worked fine with both 3776spBIOS.rom and 3840spBIOS.rom but would get terrible artifacting with the 4096spBIOS.rom.
    My card had one one the cores near the center of the die disabled and then all the ones on the edge except the second from the right one on the row where the center one was disabled.
    I noticed that the 4096spBIOS.rom was enabling that center core which obviously is bad.
    So I poked around at the perl script and noticed there was an undocumented option for the -p command which is 3. I generated the rom file with that option and it only enabled the right two rows and left the one in the center enabled! I burned in and this time rock solid.
    I would recommenced updating your scripts to build a rom file with the -p 3 option (instead of just 1 and 2 and fully unlocked)

    ReplyDelete
    Replies
    1. Hey, im not expert with BIoses but could u send me that updated 4096spBIOS.rom i get artifacts using the Buildzoid one. please :D

      Delete
    2. So you don't really want mine, it is specific to my card.
      Just open the makeroms.bat file with notepad and change the line that says
      atomtool.py a -p 65535 FuryBIOS.rom 4096spBIOS.rom
      to
      atomtool.py a -p 3 FuryBIOS.rom 4096spBIOS.rom
      and rerun the tool and flash that rom.
      That will leave whatever CU actually is bad disabled and that is specific to your card.

      Delete